GUIDEcx - Temporary API instability – Incident details

All systems operational

Temporary API instability

Resolved
Degraded performance
Started about 2 months agoLasted about 2 hours

Affected

OpenAPI

Degraded performance from 4:57 PM to 5:52 PM, Operational from 6:13 PM to 6:35 PM

API v1

Degraded performance from 4:57 PM to 5:52 PM, Operational from 6:13 PM to 6:35 PM

API v2

Degraded performance from 4:57 PM to 5:52 PM, Operational from 6:13 PM to 6:35 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. We apologize for the back and forth on this but have tried to be as transparent and proactive as possible. At this point we do believe the issue is resolved and our testing has not indicated any major issues. However, we have found that there might be a few recipes that might need modifications. We will handle these on a case by case basis, but at this time there isn't any degraded performance of the API for our customer base as a whole.

  • Identified
    Identified

    We are continuing to work on a fix for this incident. We are running into one issue during project creation through the API. The rest of the API has been restored to working properly.

  • Resolved
    Resolved

    This incident has been resolved. We will continue to monitor, functionality has been restored. Thank you for your patience.

  • Identified
    Identified

    This was caused by an edge case around our load balancer. Applying a fix now.

  • Investigating
    Update

    We are still investigating and are continuing to troubleshoot.

  • Investigating
    Investigating
    We are currently investigating this incident.