Message queue latency has returned to normal. The team fixed an autoscaling policy that was preventing the queue from scaling correctly with the spikes in traffic. We will continue monitoring and implementing some additional enhancements.
Update
Update
Short-term fixes have been released to provide more resources to the message queue, as the queue length is continuing to spike above normal ranges. The team is continuing their research into the root cause.
Monitoring
Monitoring
Message queue has returned to normal and the team is still investigating root cause.
Investigating
Investigating
The team is monitoring higher than usual activity on the API message queue, resulting in increased latency of updates to third-party systems, including Jira and Salesforce. Changes will not be lost, only delayed while the message queue is processed.