GUIDEcx - Platform Performance and Latency Issues – Incident details

All systems operational

Platform Performance and Latency Issues

Resolved
Operational
Started over 3 years agoLasted about 3 hours

Affected

Web Application

Operational from 3:01 PM to 5:34 PM

Project Management

Operational from 3:01 PM to 5:34 PM

Updates
  • Resolved
    Resolved

    The performance issues this morning have been resolved.

  • Investigating
    Investigating

    Users are experiencing higher latency when loading pages. We are actively investigating these issues.